neděle 6. listopadu 2011

Ubuntu 11.10 > LMDE

V pátek jsem se rozhodl, že na firemním noteboku vyzkouším Poslední verzi distribuce Ubuntu s označením Oneiric Ocelot 11.10. Tento release jsem testoval ve virtualizaci, takže jsem tušil o co se jedná. Doposud jsem používal Lucid Lynx 10.04.3 LTS a moc se mi jej nechtělo opouštět. Díky LTS bych jej mohl spokojeně používat až do 042013. Kolega v práci si 11.10 moc pochvaloval a na práci s Unity se prý dá zvyknout.

Instalace byla bez problémů, osobně mě překvapil instlátor, který umí používat i wifi bezdrátové spojení. Tato vlastnost se zřejmně časem objeví ve všech ostatních distribucích.

Co se Unity týče, moc se mi nelíbí a více jsem si sliboval od používání Gnome Shell neboli Gnome3. Již v minulosti jsem obě prostředí testoval. Koexistence obou prostředí v jednom systému je dobrá. V dřívějších dobách - distribucích tato možnost tuším nebyla možná. Před instalací jsem si udělal zálohu /etc a /home dále je dobré poznamenat si seznam instalovaných balíčků.

Po instalaci jsem si liboval, že to bude v pohodě, ale ejhle. Emailový klient Evolution, který byl z úvodní instalace odstraněn nefungoval jak by měl, přesněji přestal fungovat úplně, což bylo pro mě dosti fatální. Dále mě hodně zarazila neexistence balíčků seahorse-plugins, totem-plugins. Někde jsem vygooglil, že jsou plné chyb a že se asi objeví až ve 12.04, což je dosti nepochopitelné. Dále jsem se pokoušel Unity nějak umravnit a za nápomoc jsem povolal pěkně ucelený článek na rootu. V sobotu večer jsem Evolution neumravnil a pak už došla trpělivost. Doslova jsem se nasral a vzpálil si DVD linuxmint-201109-gnome-dvd-64bit.iso a bylo vymalováno.

Distribuci Linux Mint neznám moc dlouho, ale na domácí plečce na přehrávání pohádek jsem si jí ochmatal a přišla mi jako vcelku dobrá a použitelná. Mint distribuce je postavená na Ubuntu nebo Debinu. Ubuntí verzi jsem testil již dříve. Zato LMDE neboli Linux Mint Debian Edition je takzvaná "rolling distribution". To má malou nevýhodu, že se využívají Debian Testing balíky. To by mohlo mít za následek nestabilitu. I přes to jsem se jej rozhodl používat.

Instalátor je více ořezaný, než ten Ubuntí, ale to na funkcni nemělo vliv. Po instalaci se aktualizovalo asi 400 balíků. Dále jsem obnovil data ze zálohy a vše funguje jak bych si představoval. Problém nastal jen s VMware Workstation 7.1.x, která si nechtěla porozumět s kernelem 3.0.x. Tento identický problém jsem ovšem řešil i na Ubuntu 11.10. Postup na řešení bude v dalším příspěvku.

Pevně věřím, že budu s LMDE spokojen a nebudu neustále utloukán nefunkčními novinkami. Jsem smířen s tím, že komunitní podpora není stejná jako ta od Canonicalu. Ubuntu jsem používal od verze 6.06 LTS. Distribuci Ubuntu dlouhodobě vnímám jako inovátorskou distribuci, u níž má cenu používat jen LTS verze. Ty ostatní často nefungují. Taktéž věřím že LTS nestratí své dřívější kvality.

1 komentář:

Hynek řekl(a)...

Ahoj, já díky Unity přestal UBUNTU používat a radši mám čistokrevný Debian. A ? Spokojenost.